Does my iPad meet the system requirements for Read&Write for iPad

Read&Write for iPad requires the iOS 8 or higher operating system to be installed on the iPad. If you're using an operating system lower than iOS 8 then sorry you will be unable to download the app from the App Store.