Browsealoud System Requirements

PC:

Internet Explorer version 11 and MS Edge
Firefox (latest release)
Chrome (latest release)

Mac:

Safari (latest release)

Chromebook:
Latest release Mobile:

iOS:

Safari (iPad, iPhone, iPod Touch, latest release)

Android:

Chrome (Android v3 and greater, latest release) 

Please note: We only support version 11 of Internet Explorer as Microsoft does not support anything under version 11, and has stopped security updates for IE versions 8, 9 & 10. Please see their article below:

https://www.microsoft.com/en-gb/WindowsForBusiness/End-of-IE-support?wa=wsignin1.0